BNPL Direct Debit Checkout degraded for new buyers
Incident Report for Hokodo
Resolved
This incident has been resolved.
Posted May 07, 2024 - 09:52 UTC
Monitoring
Our Provider have confirmed the incident is resolved
Posted May 07, 2024 - 09:40 UTC
Identified
We’ve noticed degradation in performance of one of our payment providers. This may be affecting new buyers who wish to checkout with direct debit.

We are waiting for an update from our provider.
Posted May 07, 2024 - 09:33 UTC
This incident affected: BNPL checkout and Confirmation & payment portal.